Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 29, 2025 - 00:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 28, 2025 - 15:24 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 27, 2025 - 05:58 UTC
Scheduled
We will be performing scheduled maintenance during this time. During the maintenance window, some or all services (Main Website, News, Tournament Portal, Email, and Login) may be temporarily unavailable.
We appreciate your patience and understanding while we work to improve our platform.
✅ All services will be restored immediately after the maintenance is complete.
Posted Aug 27, 2025 - 05:57 UTC
This scheduled maintenance affected: Support Portal, Home page, Email Service, Tournament Registration Portal, and SSGAMING.